$re = '/\.[^{\s]*(?=\s*{)/';
$str = '.text-center { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/';
$subst = ".a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;