$re = '/(\[module[^]]*id="[^"]*\d)(.*?)(\[\/module[^]]*\])/m';
$str = '[section][module_text id="123"]text[/module][module_number id=""]000[/module][/section]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);