re = /(\[module[^]]*id="[^"]*\d)(.*?)(\[\/module[^]]*\])/m
str = '[section][module_text id="123"]text[/module][module_number id=""]000[/module][/section]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end