// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\[module[^]]*id="[^"]*\d)(.*?)(\[\/module[^]]*\])"#).unwrap();
let string = "[section][module_text id=\"123\"]text[/module][module_number id=\"\"]000[/module][/section]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}