#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<digit> (?: [0-9] ) )" & @CRLF & _
" (?<factor> (?: \( (?&exp) \) | (?&digit) ) )" & @CRLF & _
" (?<term> (?: (?&term) \* (?&term) | (?&factor) ) )" & @CRLF & _
" (?<exp> (?: (?&exp) \+ (?&exp) | (?&term) ) )" & @CRLF & _
" )" & @CRLF & _
" ^ (?&exp) $"
Local $sString = "1+2*3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")