// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?(DEFINE)
(?<digit> (?: [0-9] ) )
(?<factor> (?: \( (?&exp) \) | (?&digit) ) )
(?<term> (?: (?&term) \* (?&term) | (?&factor) ) )
(?<exp> (?: (?&exp) \+ (?&exp) | (?&term) ) )
)
^ (?&exp) $").unwrap();
let string = "1+2*3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}