import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<digit> (?: [0-9] ) )\n"
+ " (?<factor> (?: \\( (?&exp) \\) | (?&digit) ) )\n"
+ " (?<term> (?: (?&term) \\* (?&term) | (?&factor) ) )\n"
+ " (?<exp> (?: (?&exp) \\+ (?&exp) | (?&term) ) )\n"
+ " )\n"
+ " ^ (?&exp) $";
final String string = "1+2*3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}