using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<digit> (?: [0-9] ) )
(?<factor> (?: \( (?&exp) \) | (?&digit) ) )
(?<term> (?: (?&term) \* (?&term) | (?&factor) ) )
(?<exp> (?: (?&exp) \+ (?&exp) | (?&term) ) )
)
^ (?&exp) $";
string input = @"1+2*3";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}