const regex = /(?:(:\w+:))(.)*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(:\\w+:))(.)*', 'mg')
const str = `:the: :super: :AESTHETIC: :ship: :build:`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);