using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>[a-zA-Z0-9]+ de [0-9]+;?)+$";
string input = @"AA123 de 123456;
BB456 de 123456
AA123 de 123456;
BB456 de 123456;
AA123 de 123456;
AA123 de 123456
AA123 de 123456;;
AA123 de 123456;BB456 de 123456
AA123 de 123456;BB456 de 123456;
AA126 de 61234561 de 23456123456 de 12345634561 de 23452345612345612 de 345612345634561234 de 5612345612345612345634561234523 de 45234561234561234561234563456123452345612345612345612345634561234561234 de 5612345612345656123423456123456123456A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}