const regex = /^(?>[a-zA-Z0-9]+ de [0-9]+;?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>[a-zA-Z0-9]+ de [0-9]+;?)+$', 'gm')
const str = `AA123 de 123456;
BB456 de 123456
AA123 de 123456;
BB456 de 123456;
AA123 de 123456;
AA123 de 123456
AA123 de 123456;;
AA123 de 123456;BB456 de 123456
AA123 de 123456;BB456 de 123456;
AA126 de 61234561 de 23456123456 de 12345634561 de 23452345612345612 de 345612345634561234 de 5612345612345612345634561234523 de 45234561234561234561234563456123452345612345612345612345634561234561234 de 5612345612345656123423456123456123456A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}