use strict;
my $str = 'AA123 de 123456;
BB456 de 123456
AA123 de 123456;
BB456 de 123456;
AA123 de 123456;
AA123 de 123456
AA123 de 123456;;
AA123 de 123456;BB456 de 123456
AA123 de 123456;BB456 de 123456;
AA126 de 61234561 de 23456123456 de 12345634561 de 23452345612345612 de 345612345634561234 de 5612345612345612345634561234523 de 45234561234561234561234563456123452345612345612345612345634561234561234 de 5612345612345656123423456123456123456A';
my $regex = qr/^(?>[a-zA-Z0-9]+ de [0-9]+;?)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}