$re = '/^(?>[a-zA-Z0-9]+ de [0-9]+;?)+$/m';
$str = 'AA123 de 123456;
BB456 de 123456
AA123 de 123456;
BB456 de 123456;
AA123 de 123456;
AA123 de 123456
AA123 de 123456;;
AA123 de 123456;BB456 de 123456
AA123 de 123456;BB456 de 123456;
AA126 de 61234561 de 23456123456 de 12345634561 de 23452345612345612 de 345612345634561234 de 5612345612345612345634561234523 de 45234561234561234561234563456123452345612345612345612345634561234561234 de 5612345612345656123423456123456123456A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);