#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\bunlock\b|\bun-lock\b|\bdownlock\b|\bdown-lock\b|\bre-lock\b|\brelock\b|\block\b)?"
Local $sString = "un-lock"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")