using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bunlock\b|\bun-lock\b|\bdownlock\b|\bdown-lock\b|\bre-lock\b|\brelock\b|\block\b)?";
string input = @"un-lock";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}