re = /(\bunlock\b|\bun-lock\b|\bdownlock\b|\bdown-lock\b|\bre-lock\b|\brelock\b|\block\b)?/i
str = 'un-lock'
# Print the match result
str.match(re) do |match|
puts match.to_s
end