$re = '/(\bunlock\b|\bun-lock\b|\bdownlock\b|\bdown-lock\b|\bre-lock\b|\brelock\b|\block\b)?/i';
$str = 'un-lock';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);