import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z](?<![a-zA-Z][A-Z])(?:[A-Z]|[-\\s/\\\\])*(?<=[A-Z])(?![a-zA-Z])";
final String string = "example 1:\n\n"
+ "string = string = 'MY MANAGEMENT PRIOR ASSESSMENT / NEW PLANNING SUPRESS RATE - TEAM : 14 \n\n"
+ "example 2: \n\n"
+ "string2 = 'SPORT/TRACK INFO ¶·»Sport Coverage(s): All Sport primary ¶·»WWE Hi-Low: ¶·»BBC Hi-Low: ¶·»Sports Issues: can run forever ¶·»BBC Sports: kjkj '\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}