import re
regex = re.compile(r"[A-Z](?<![a-zA-Z][A-Z])(?:[A-Z]|[-\s/\\])*(?<=[A-Z])(?![a-zA-Z])", flags=re.MULTILINE)
test_str = ("example 1:\n\n"
"string = string = 'MY MANAGEMENT PRIOR ASSESSMENT / NEW PLANNING SUPRESS RATE - TEAM : 14 \n\n"
"example 2: \n\n"
"string2 = 'SPORT/TRACK INFO ¶·»Sport Coverage(s): All Sport primary ¶·»WWE Hi-Low: ¶·»BBC Hi-Low: ¶·»Sports Issues: can run forever ¶·»BBC Sports: kjkj '\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")