use strict;
my $str = 'example 1:
string = string = \'MY MANAGEMENT PRIOR ASSESSMENT / NEW PLANNING SUPRESS RATE - TEAM : 14
example 2:
string2 = \'SPORT/TRACK INFO ¶·»Sport Coverage(s): All Sport primary ¶·»WWE Hi-Low: ¶·»BBC Hi-Low: ¶·»Sports Issues: can run forever ¶·»BBC Sports: kjkj \'
';
my $regex = qr/[A-Z](?<![a-zA-Z][A-Z])(?:[A-Z]|[-\s/\\])*(?<=[A-Z])(?![a-zA-Z])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}