package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?isU)(<div [^>]*class="[^"]*p-navgroup p-account[^"]*"[^>]*>)`)
var str = `<div class="p-navgroup p-account {{ $xf.visitor.user_id ? 'p-navgroup--member' : 'p-navgroup--guest' }}">
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}