re = /(<div [^>]*class="[^"]*p-navgroup p-account[^"]*"[^>]*>)/i
str = '<div class="p-navgroup p-account {{ $xf.visitor.user_id ? \'p-navgroup--member\' : \'p-navgroup--guest\' }}">
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end