$re = '#(<div [^>]*class="[^"]*p-navgroup p-account[^"]*"[^>]*>)#isU';
$str = '<div class="p-navgroup p-account {{ $xf.visitor.user_id ? \'p-navgroup--member\' : \'p-navgroup--guest\' }}">
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);