const regex = new RegExp('(<div [^>]*class="[^"]*p-navgroup p-account[^"]*"[^>]*>)', 'is')
const str = `<div class="p-navgroup p-account {{ \$xf.visitor.user_id ? 'p-navgroup--member' : 'p-navgroup--guest' }}">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}