#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(([A-TU-Z][0-9][0-9AB]\.?[0-9A-TV-Z]{0,4}(?:\s\(([\w\s]+)\))?),?)*$"
Local $sString = "S42.3" & @CRLF & _
"S42.3 S41.87!" & @CRLF & _
"S42.3,S41.87" & @CRLF & _
"E10.30+ H36.0*" & @CRLF & _
"E10.30G,H36.0LV"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")