package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^(([A-TU-Z][0-9][0-9AB]\.?[0-9A-TV-Z]{0,4}(?:\s\(([\w\s]+)\))?),?)*$`)
var str = `S42.3
S42.3 S41.87!
S42.3,S41.87
E10.30+ H36.0*
E10.30G,H36.0LV`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}