import Foundation
let pattern = #"^(([A-TU-Z][0-9][0-9AB]\.?[0-9A-TV-Z]{0,4}(?:\s\(([\w\s]+)\))?),?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
S42.3
S42.3 S41.87!
S42.3,S41.87
E10.30+ H36.0*
E10.30G,H36.0LV
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)