$re = '/^(([A-TU-Z][0-9][0-9AB]\.?[0-9A-TV-Z]{0,4}(?:\s\(([\w\s]+)\))?),?)*$/ms';
$str = 'S42.3
S42.3 S41.87!
S42.3,S41.87
E10.30+ H36.0*
E10.30G,H36.0LV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);