using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/home\/user\/web\/([[:alnum:]].*?)\/public_html\/([[:alnum:]].*)?";
string input = @"
/home/user/web/domain.tld/public_html/publichtm2
/home/user/web/domain.tld/public_html/publichtm2/
/home/user/web/domain.tld/public_html/publichtm2/sub/sub1/sub_1/sub2/sub_2/
/home/user/web/domain.tld/public_html/public_html
/home/user/web/domain.tld/public_html/public_html/
/home/user/web/domain.tld/public_html/public_html/sub/sub1/sub_1/sub2/sub_2/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}