$re = '/\/home\/user\/web\/([[:alnum:]].*?)\/public_html\/([[:alnum:]].*)?/m';
$str = '
/home/user/web/domain.tld/public_html/publichtm2
/home/user/web/domain.tld/public_html/publichtm2/
/home/user/web/domain.tld/public_html/publichtm2/sub/sub1/sub_1/sub2/sub_2/
/home/user/web/domain.tld/public_html/public_html
/home/user/web/domain.tld/public_html/public_html/
/home/user/web/domain.tld/public_html/public_html/sub/sub1/sub_1/sub2/sub_2/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);