package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/home\/user\/web\/([[:alnum:]].*?)\/public_html\/([[:alnum:]].*)?`)
var str = `
/home/user/web/domain.tld/public_html/publichtm2
/home/user/web/domain.tld/public_html/publichtm2/
/home/user/web/domain.tld/public_html/publichtm2/sub/sub1/sub_1/sub2/sub_2/
/home/user/web/domain.tld/public_html/public_html
/home/user/web/domain.tld/public_html/public_html/
/home/user/web/domain.tld/public_html/public_html/sub/sub1/sub_1/sub2/sub_2/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}