import Foundation
let pattern = #"\/home\/user\/web\/([[:alnum:]].*?)\/public_html\/([[:alnum:]].*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/home/user/web/domain.tld/public_html/publichtm2
/home/user/web/domain.tld/public_html/publichtm2/
/home/user/web/domain.tld/public_html/publichtm2/sub/sub1/sub_1/sub2/sub_2/
/home/user/web/domain.tld/public_html/public_html
/home/user/web/domain.tld/public_html/public_html/
/home/user/web/domain.tld/public_html/public_html/sub/sub1/sub_1/sub2/sub_2/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)