#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)appDesc\"\s:\s\"(?<appDesc>[^\"]+)"
Local $sString = "2023-05-02 22:27:20,100 | info application status https:www.codeurl" & @CRLF & _
"[" & @CRLF & _
"Response: 200 ok- https:www.codeurl" & @CRLF & _
""appDesc" : "User not within error limit"" & @CRLF & _
"{" & @CRLF & _
""appcd" : "0"," & @CRLF & _
""appDesc" : "fraud app dected risk tolerance"" & @CRLF & _
"} ]," & @CRLF & _
"" & @CRLF & _
"2023-05-02 22:27:20,100 | info application status https:www.codeurl" & @CRLF & _
"[" & @CRLF & _
"Response: 200 ok- https:www.codeurl" & @CRLF & _
""appDesc" : "User not within error limit"" & @CRLF & _
"{" & @CRLF & _
""appcd" : "0"," & @CRLF & _
""appDesc" : "fraud app dected risk tolerance"" & @CRLF & _
"} ],"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")