use strict;
my $str = '2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
"appDesc" : "User not within error limit"
{
"appcd" : "0",
"appDesc" : "fraud app dected risk tolerance"
} ],
2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
"appDesc" : "User not within error limit"
{
"appcd" : "0",
"appDesc" : "fraud app dected risk tolerance"
} ],';
my $regex = qr/appDesc\"\s:\s\"(?<appDesc>[^\"]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}