using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"appDesc\""\s:\s\""(?<appDesc>[^\""]+)";
string input = @"2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
""appDesc"" : ""User not within error limit""
{
""appcd"" : ""0"",
""appDesc"" : ""fraud app dected risk tolerance""
} ],
2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
""appDesc"" : ""User not within error limit""
{
""appcd"" : ""0"",
""appDesc"" : ""fraud app dected risk tolerance""
} ],";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}