$re = '/appDesc\"\s:\s\"(?<appDesc>[^\"]+)/m';
$str = '2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
"appDesc" : "User not within error limit"
{
"appcd" : "0",
"appDesc" : "fraud app dected risk tolerance"
} ],
2023-05-02 22:27:20,100 | info application status https:www.codeurl
[
Response: 200 ok- https:www.codeurl
"appDesc" : "User not within error limit"
{
"appcd" : "0",
"appDesc" : "fraud app dected risk tolerance"
} ],';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);