#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([1-9]\d*|0)(?!\d)(\.\d+)?"
Local $sString = "asd 0001.23 gdg" & @CRLF & _
"df0ddsfg" & @CRLF & _
"fgh9.43dsg" & @CRLF & _
"dfdg5555sdfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")