using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1-9]\d*|0)(?!\d)(\.\d+)?";
string input = @"asd 0001.23 gdg
df0ddsfg
fgh9.43dsg
dfdg5555sdfg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}