import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]\\d*|0)(?!\\d)(\\.\\d+)?";
final String string = "asd 0001.23 gdg\n"
+ "df0ddsfg\n"
+ "fgh9.43dsg\n"
+ "dfdg5555sdfg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}