$re = '/([1-9]\d*|0)(?!\d)(\.\d+)?/';
$str = 'asd 0001.23 gdg
df0ddsfg
fgh9.43dsg
dfdg5555sdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);