using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+/\d+(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b";
string input = @"BP 98/60
BP 108/60
BP 96/60
BP 120/75
Blood Pressure 106/63
B/P - Systolic 104
B/P - Diastolic 72
BP-Sitting 109/70 mmH
BP: 101/72
Systolic Blood Pressure 100 mmHg
Diastolic Blood Pressure 68 mmHg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}