re = /\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+\/\d+(?: mmHg?)?|B\/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b/m
str = 'BP 98/60
BP 108/60
BP 96/60
BP 120/75
Blood Pressure 106/63
B/P - Systolic 104
B/P - Diastolic 72
BP-Sitting 109/70 mmH
BP: 101/72
Systolic Blood Pressure 100 mmHg
Diastolic Blood Pressure 68 mmHg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end