import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:BP:?(?:-Sitting)?|Blood Pressure) \\d+/\\d+(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \\d+|(?:Sys|Dias)tolic Blood Pressure \\d+ \\w+\\b";
final String string = "BP 98/60\n"
+ "BP 108/60\n"
+ "BP 96/60\n"
+ "BP 120/75\n"
+ "Blood Pressure 106/63\n"
+ "B/P - Systolic 104\n"
+ "B/P - Diastolic 72\n"
+ "BP-Sitting 109/70 mmH\n"
+ "BP: 101/72\n"
+ "Systolic Blood Pressure 100 mmHg\n"
+ "Diastolic Blood Pressure 68 mmHg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}