const regex = /^(?:GET\s+\/)(?'stranka'.*?)(?:\?(?'parametry'.*?)){0,1}(?:#(?'kapitola'.*?))*(?:\s+HTTP\/.*)$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:GET\\s+\\\/)(?\'stranka\'.*?)(?:\\?(?\'parametry\'.*?)){0,1}(?:#(?\'kapitola\'.*?))*(?:\\s+HTTP\\\/.*)$', 'gim')
const str = `GET /Test?parametr=1 HTTP/1.1
GET /Test HTTP/1.1
GET /Test?parametr=1#Zde HTTP/1.1
GET /Test?parametr1=1¶metr2=2#Zde HTTP/1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}