// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(?:GET\s+\/)(?'stranka'.*?)(?:\?(?'parametry'.*?)){0,1}(?:#(?'kapitola'.*?))*(?:\s+HTTP\/.*)$").unwrap();
let string = "GET /Test?parametr=1 HTTP/1.1
GET /Test HTTP/1.1
GET /Test?parametr=1#Zde HTTP/1.1
GET /Test?parametr1=1¶metr2=2#Zde HTTP/1.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}