$re = '/^(?:GET\s+\/)(?\'stranka\'.*?)(?:\?(?\'parametry\'.*?)){0,1}(?:#(?\'kapitola\'.*?))*(?:\s+HTTP\/.*)$/im';
$str = 'GET /Test?parametr=1 HTTP/1.1
GET /Test HTTP/1.1
GET /Test?parametr=1#Zde HTTP/1.1
GET /Test?parametr1=1¶metr2=2#Zde HTTP/1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);