$re = '/^([^\S]?LUL[\s]?)+$|^([\S]+LUL[\s]?)+$|^[ах]+[\s]*$/im';
$str = 'LUL LUL LUL LUL
blackufaLUL LUL LUL LUL
blackufaLUL as w qddd 
blackufaLUL blackufaLUL
blackufaLUL 
blackufaLUL
LUL 
blackufaLUL
blackufaLUL blackufaLUL
blackufaLUL
аххахах
ахахах
хааха
страх 
страхах
ахахах   
фафывафывацуацлжыд жывшапд од lul
lul
^([\\S]+LUL[\\s]?)+$ - blackufaLUL blackufaLUL
^([^\\S]?LUL[\\s]?)+$ - LUL LUL LUL
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);