// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)mp4="(?<video_url>[^"]+)""#).unwrap();
let string = "mp4=\"https://example.com/wp-content/uploads/2023/11/file_example-MP4-480_1_5MG.mp4\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}