#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+)\s(\d+)(.*(?:\r?\n(?!\w+\s\d).*)*)"
Local $sString = "Abc 123 def" & @CRLF & _
"ghi" & @CRLF & _
"jkl" & @CRLF & _
"Abc 123 def ghi jkl mno" & @CRLF & _
"Abc 123 def ghi jkl " & @CRLF & _
"mno"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")