re = /^(\w+)\s(\d+)(.*(?:\r?\n(?!\w+\s\d).*)*)/m
str = 'Abc 123 def
ghi
jkl
Abc 123 def ghi jkl mno
Abc 123 def ghi jkl
mno'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end